[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: build system failure (first try)



Gah, I remember that one now.  I had the same thing with mp7, and now
I forgot what I did to alleviate it.  It has to do with the "[[" and
the shell; by chance are you using ubuntu?

g

On May 2, 12:34 pm, Olivier Goudron <[email protected]> wrote:
> Hello,
>
> I am trying to build ttylinux with the build system and i have the following
> problem.
>
> The xbuildtool phase is OK and i have this message :
> i486-generic-linux-gnu cross-tool is complete.
>
> Then, after doing "make dload" i try this command (as root) :
> make dist
>
> and this is the error message i get :
>
> [email protected]:~/ttylinux-src-mp8# make dist
> Remove the built items.
> ./ttylinux-config.sh: 199: [[: not found
>
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> site pre clean
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>
> => Removing file system image, boot CD image, SDCard image.
> => Removing boot CD-ROM, SD Card staging areas.
> => Removing kernel and module tree, if any.
> => Removing kernel modules package, if any.
> => Removing the packages:
>    -> Removing build-root/ contents.
>    -> Removing pkg-bin/ binary packages.
>    -> Removing var/log/ build logs.
> Clean FAILED.
> make: *** [clean] Erreur 1
>
> I have changed nothing in "ttylinux-config.sh" so it should not be
> a corrupted file problem.
> Does someone have an idea ?
>
> Bests regards, Olivier Goudron
>
> --
> /*
> *Olivier Goudron*, Formateur et Ingénieur système Linux.
> *Téléphone : *09 72 26 34 75
> *Email :* [email protected]
> *Site Web :*http://goudron.fr
> */