[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building xbuildtool 1.0 fails with ubuntu 11.10



I found the possible reason:

mawk: scripts/gen-sorted.awk: line 19: regular _expression_ compile failed (bad class -- [], [^] or [)
/[^
mawk: scripts/gen-sorted.awk: line 19: syntax error at or near ]
mawk: scripts/gen-sorted.awk: line 19: runaway regular _expression_ /, "", subd ...
make[2]: Leaving directory `/home/martin2/Source/ttylinux-build-10.0/xbuildtool-1.0/build/glibc-2.13'
make[2]: Entering directory `/home/martin2/Source/ttylinux-build-10.0/xbuildtool-1.0/build/glibc-2.13'
{ echo '#include "posix/bits/posix1_lim.h"'; \
 echo '#define _LIBC 1'; \
 echo '#include "misc/sys/uio.h"'; } | \

So I installed the newest version of mawk, but it does not help.

mawk 1.3.4 20100625
Copyright 2010, Thomas E. Dickey
Copyright 1996, Michael D. Brennan

internal regex
compiled limits:
max NF             32767
sprintf buffer      2040

Any ideas?

Regards
Martin



Am Donnerstag, 22. März 2012 20:03:35 UTC+1 schrieb Martin:
Hi,

a few days ago I found an article about ttylinux and it's a very
interesting project for me. I downloaded the ISO and installed it on
an ETX board. It works fine, but I'm missing a few things like telnet.
Now I want to build it myself, but building the xbuildtool for i686
stops at glibc-2.13 with an error. Does anyone has a tip for me what's
going wrong or where to have a look?

Thanks
Martin

[email protected]:~/Source/​ttylinux-build-10.0/​xbuildtool-1.0$ make
i686-2.13-gnu
rm -f xbt-build-config.sh
cp config/ttyl-pc_i686.cfg xbt-build-config.sh
./scripts/_build-toolchain.sh

xbuildtool configured for cross-development tool chain:

  Host: x86_64-pc-linux-gnu
Target: i686-generic-linux-gnu
 Tools: binutils-2.22 gcc-4.4.6 [gmp-4.3.2, no MPC, mpfr-2.4.2]
  Libc: glibc-2.13
 Linux: i386 linux-2.6.38.1

build gcc with c++: yes
  use thread model: nptl

i> Getting source code packages [be patient, this will not lock up].
i> Local cache directory: /home/martin2/Download
i> Checking binutils-2.22 ........ have it.
i> Checking gmp-4.3.2 ............ have it.
i> Checking mpfr-2.4.2 ........... have it.
i> Checking gcc-4.4.6 ............ have it.
i> Checking glibc-2.13 ........... have it.
i> Checking linux-2.6.38.1 ....... have it.
=> md5sum binutils-2.22.tar.bz2 ..... OK
(​ee0f10756c84979622b992a4a61ea3​f5)
=> md5sum gmp-4.3.2.tar.bz2 ......... OK
(​dd60683d7057917e34630b4a787932​e8)
=> md5sum gcc-4.4.6.tar.bz2 ......... OK
(​ab525d429ee4425050a554bc9247d6​c4)
=> md5sum glibc-2.13.tar.bz2 ........ OK
(​38808215a7c40aa0bb47a5e6d3d124​75)
=> md5sum linux-2.6.38.1.tar.bz2 .... OK
(​7716316e5fa36e570df2d79dc60675​91)

Getting linux-2.6.38.1 Headers .... done
Building binutils-2.22 ............ done [binutils-2.22 is complete]
Building library gmp-4.3.2 ........ done [gmp-4.3.2 is complete]
Building library mpfr-2.4.2 ....... done [mpfr-2.4.2 is complete]
Building gcc-4.4.6 Stage 1 ........ done
Building glibc-2.13 Stage 1 ....... make: *** [i686-2.13-gnu] Fehler 1