[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ttylinux:218] Re: Building xbuildtool 1.0 fails with ubuntu 11.10



Hi Douglas,

thank you very much!

gawk is not installed on Ubuntu by default. I've installed it and the build runs fine:

=> Adjusting cross-tool chain.
=> Completed cross-tools adjustments.
i686-generic-linux-gnu cross-tool is complete.
=> 33 minutes 45 seconds

Best regards
Martin


Am 22. März 2012 22:27 schrieb Douglas Jerome <[email protected]>:
On 03/22/12 13:50, Martin wrote:
I found the possible reason:

mawk: scripts/gen-sorted.awk: line 19: regular _expression_ compile failed
(bad class -- [], [^] or [)
/[^
mawk: scripts/gen-sorted.awk: line 19: syntax error at or near ]
mawk: scripts/gen-sorted.awk: line 19: runaway regular _expression_ /, "",
subd ...
make[2]: Leaving directory
`/home/martin2/Source/ttylinux-build-10.0/xbuildtool-1.0/build/glibc-2.13'
make[2]: Entering directory
`/home/martin2/Source/ttylinux-build-10.0/xbuildtool-1.0/build/glibc-2.13'
{ echo '#include "posix/bits/posix1_lim.h"';\
echo '#define _LIBC 1';\
echo '#include "misc/sys/uio.h"'; } |\

So I installed the newest version of mawk, but it does not help.

mawk 1.3.4 20100625
Copyright 2010, Thomas E. Dickey
Copyright 1996, Michael D. Brennan

internal regex
compiled limits:
max NF 32767
sprintf buffer 2040

Any ideas?

Regards
Martin

mawk will not work.

Did you run "make setup" or "./configure" ? If not,
then please do it. If so did you see the the warning
against mawk?

Install gnu awk; I think it is called gawk, then try
rebuilding:
    $ make clean
    $ make i686-2.13-gnu

--
Douglas Jerome