[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ttylinux:310] Unable to built xtools for i686 / 14.1



Thank you,

  v14.1-ttylinux-08nov2012.tar.gz work fine, I used archive "djerome-ttylinux-v14.1-ttylinux-08nov2012-9-gb378c94.tar.gz" and it did not work.

  I have one technical question or problem else. I am using ramdisk in cpio format, not ext2. Daemon /sbin/udevd in v12.1 automatically mount devtmpfs to /dev directory. But now  /lib/udev/udevd does not mount devtmpfs automatically in v14.1 and I had to add mount devtmpfs to rc.sysinit scrip after proc and sysfs mounts.

  Is the behaviour of new udevd correct? Why do not mount newer version of udevd the devtmpfs when it started from cpio ramdisk?

  Thanks for your experiences.

  Reg.


On Saturday, February 16, 2013 3:35:27 AM UTC+1, djerome wrote:
On 02/15/13 04:31, [email protected] wrote:
> Hi.
>
>    I am trying to build ttylinux 14.1 for i686 platform, but I have
> primary problem to build xtools.
>
>    I had to modify CFLAGS for cloog library in file
> scripts/gcc/gcc-methods.sh - CFLAGS="-I${XBT_XHOST_DIR}/usr/include
> -L${XBT_XHOST_DIR}/usr/lib -fexceptions". Cloog library reguire gmp
> library and I had to add -L option.
>
>    But now is problem to "Building gcc-4.6.3 Stage 1". I have got many
> hundreds undefined symbols:
>
> ....
>
>    May anybody help me or send advice, how to compile xtools?
>
>    How I can remove cloog and ppl from build?
>
>    Thanks very much.
>
>    Reg.
>
> --
> You received this message because you are subscribed to the Google
> Groups "ttylinux" group.
> To unsubscribe from this group and stop receiving emails from it, send
> an email to [email protected]googlegroups.com.
> For more options, visit https://groups.google.com/groups/opt_out.

I am a day late, sorry. I was away from computers and the Internet
all yesterday.

There is no cloog in ttylinux 14.1; you are using a wrong version
of the build system. This probably is my mistake. I am bad with
git.

The current version from the git repo may be in bad shape as I am
updating to the next "release". I am trying to keep it so that most
of the build system works.

Look at this page:
https://github.com/djerome/ttylinux/tags

You want to download this:
https://github.com/djerome/ttylinux/archive/v14.1-ttylinux-08nov2012.tar.gz

--
Douglas Jerome