[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [ttylinux] Re: Problem with dual networks in Virtualbox



On 02/14/14 07:44, Cosmin Cimpoi wrote:
Hello,

I am also having an issue with /sbin/route del and add on boot.
I tried adding the comamnds to rc.local but it doesn't work.
Also adding the rules to ifup-eth1 does not work.

I have a CloudStack VM that gets 2 NICs, one internal and 1 external and
I need to route all traffic through the external NIC so I can ping to
the internet.

Cosmin


On Tuesday, September 25, 2012 10:30:01 PM UTC+3, Rolf Strand wrote:

    I am trying to setup ttylinux in virtual box with two network cards.
    I have ttylinux installed on a virtual hard disk.

    My WinXP PC has two network cards.  One is connected to a network
    with DHCP and the other to a local network with static IP: 192.168.92.1.
    In the virtualbox I have the:
         network card with DHCP set to NAT
         network card with static IP set to bridged

    This setup is working well with Ubuntu, I am trying to get it
    working with smaller system image.

    In ttylinux:

    If I bring up just eth0 in DHCP mode DNS resolution works and I can
    send and receive to the the internet.
    If I bring up just eth1 with static IP 192.168.92.2, I can send and
    receive on the local network.
    If I bring up both eth0 and eth1 the traffic on eth0 stops.

    Any idea what I need to do to get both working?

--
You received this message because you are subscribed to the Google
Groups "ttylinux" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to [email protected]
For more options, visit https://groups.google.com/groups/opt_out.
Hi,

First, sorry to everyone: I split all my time these days between
busy family and 50 hour work weeks, I'm just not having much time
for ttylinux... it always looks like it will be better in a week
or two...

Cosmin, I will do what I can to help you, please be patient. I need
to know exactly which version of ttylinux you are using.

Also: I hate hate hate the newer Google Group interface. I cannot
find things. Maybe I am too lame. But I hate that thing. I hate hate hate it; I cannot find the thread that has this post. Maybe in another
10 minutes.... Damn damn damn I hate Google Groups.

Cosmin, look in /sys/class/net, you can use this bash command in
ttylinux:

     l /sys/class/net

How many ethernet interfaces? If there is only one, then the kernel
is not seeing two network interfaces, and that will be an issue
different than if there are two interfaces.

I am no clear what means internal and external interfaces; maybe
one is a virtual LAN in the cloud and one is accessible from outside the cloud. This shouldn't matter to the kernel, which I want to verify
that it is finding both interfaces.

For now, I will assume that the kernel is finding both interfaces
(but you need to check and let me know) and I will try to have
another answer about how to configure them after some research on
my part.

Thanks